Yamaha aventage Rx-1080 firmware issue

G

Golum

Audiophyte
Hello,

My aventage 1080 stopped playing sound. Then I decided to check the firmware and notice that the version I installed was "error". Yes, error.
I downloaded the latest version from yamaha website, saved in a 2Gb Kingston flash drive, and tried the firmware procedure.
During the installation procedure I could see on the unit display that the S# packages were installed and verified, but after 100% of package S6 I've got the error 020. I tried the same thing with different flash drives, all between 2Gb and 32Gb in size, all FAT32, all were formatted - same error 20. I had nothing but the bin file on the flash drive and still same error 20.
Now every time I power on I see "version error" on the unit display.
Can anybody give me some light?
Thank you.
 
Gmoney

Gmoney

Audioholic Ninja
Hello,

My aventage 1080 stopped playing sound. Then I decided to check the firmware and notice that the version I installed was "error". Yes, error.
I downloaded the latest version from yamaha website, saved in a 2Gb Kingston flash drive, and tried the firmware procedure.
During the installation procedure I could see on the unit display that the S# packages were installed and verified, but after 100% of package S6 I've got the error 020. I tried the same thing with different flash drives, all between 2Gb and 32Gb in size, all FAT32, all were formatted - same error 20. I had nothing but the bin file on the flash drive and still same error 20.
Now every time I power on I see "version error" on the unit display.
Can anybody give me some light?
Thank you.
Try a hard reset back to Factory setting if that doesn't work, get on the phone with a Yamaha tech to trouble shoot. Go to Yamaha's home page click on support for phone number call and wait. There are things they can do that you can't. If it's bricked remember that little box you checked off on? Yamaha isn't responsible when you down loaded the update and if you did something wrong and you have to ship it to a Yamaha repair facility it may be at your expense. Good luck.
 
Last edited:
G

Golum

Audiophyte
Try a hard reset back to Factory setting if that doesn't work, get on the phone with a Yamaha tech to trouble shoot. Go to Yamaha's home page click on support for phone number call and wait. There are things they can do that you can't. If it's bricked remember that little box you checked off on? Yamaha isn't responsible when you down loaded the update and if you did something wrong and you have to ship it to a Yamaha repair facility it may be at your expense. Good luck.
By hard reset you mean, go to advanced menu and initialize all, then power off? I did that, and still same thing.
I called yamaha tech...after a while he decided to escalate to a level above tech.
I am waiting for their call (48h to 72h).
Any other guesses?
 
H

Huey645

Junior Audioholic
By hard reset you mean, go to advanced menu and initialize all, then power off? I did that, and still same thing.
I called yamaha tech...after a while he decided to escalate to a level above tech.
I am waiting for their call (48h to 72h).
Any other guesses?
No, a factory reset is comprised of hitting a couple of buttons at the same time. I have a 2080, and have done it, I just don't remember which two buttons, but you can find the procedure on the web. Something like hitting the stand by and info button at the same time, or something similar to that.

Also, why not network the 1080 and do the firmware update through the machine itself? A lot less can go wrong that way.
 
G

Golum

Audiophyte
No, a factory reset is comprised of hitting a couple of buttons at the same time. I have a 2080, and have done it, I just don't remember which two buttons, but you can find the procedure on the web. Something like hitting the stand by and info button at the same time, or something similar to that.

Also, why not network the 1080 and do the firmware update through the machine itself? A lot less can go wrong that way.
Yes, I did that too. However after the factory reset the firmware version is still "error". I tried the online update, it didn't work either.
 
Gmoney

Gmoney

Audioholic Ninja
Yes, I did that too. However after the factory reset the firmware version is still "error". I tried the online update, it didn't work either.
Post up a photo of your RX-a1080 with a Screenshot of your display. powered and showing that Error code
 
TLS Guy

TLS Guy

Audioholic Slumlord
Yes, I did that too. However after the factory reset the firmware version is still "error". I tried the online update, it didn't work either.
That is the problem when a firmware update does not install correctly. If a hard reset does not solve it, then the receiver has to go to a service center to have the BIOS re-flashed. Ask them to install the latest firmware after they have re-flashed the BIOS.

Lastly, I have to ask, how did you download the updates? I ask, because you must use a reliable hardwired connection, and not Wifi for these downloads. Wifi is not reliable for these downloads. Errors more often than not, brick the receiver until the BIOS is re-flashed.
 
G

Golum

Audiophyte
That is the problem when a firmware update does not install correctly. If a hard reset does not solve it, then the receiver has to go to a service center to have the BIOS re-flashed. Ask them to install the latest firmware after they have re-flashed the BIOS.

Lastly, I have to ask, how did you download the updates? I ask, because you must use a reliable hardwired connection, and not Wifi for these downloads. Wifi is not reliable for these downloads. Errors more often than not, brick the receiver until the BIOS is re-flashed.
First trial was thru wifi. Then I tried with usb. But I guess the damage was already done.
 
lovinthehd

lovinthehd

Audioholic Jedi
Is that range of drive size accommodated for that? On at least one of my avrs there's a drive size limit for using a firmware update and think it is 256 Mb....then again I always set the automatic wifi updates off, and only install an update if I need what it does....
 
G

Golum

Audiophyte
Is that range of drive size accommodated for that? On at least one of my avrs there's a drive size limit for using a firmware update and think it is 256 Mb....then again I always set the automatic wifi updates off, and only install an update if I need what it does....
I tried with different flash drives, with sizes varying from 2Gb to 32Gb.
 
G

Golum

Audiophyte
Does anyone know how I can flash the bios again on my receiver?
 
TLS Guy

TLS Guy

Audioholic Slumlord
Does anyone know how I can flash the bios again on my receiver?
You will have to send it to a Yamaha service center to get the BIOS re-flashed. Unfortunately you have learned and expensive lesson from the "world of hard knocks."
 
Mark E. Long

Mark E. Long

Full Audioholic
You will have to send it to a Yamaha service center to get the BIOS re-flashed. Unfortunately you have learned and expensive lesson from the "world of hard knocks."
I’ve herd of this happening and was told by a higher level Yamaha tech that the more you try to update it it will eventually wipe the processor clean out of firmware and will have to have a complete factory reprogram because every time you update it copy’s the present firmware first then installs the new .
So basically it will copy bad firm ware or incomplete till there’s nothing to install and you’ll get a firmware error or in some cases it will say no firmware detected . Sometimes times it may even damage the processor. He also said most times it’s easier to just replace the whole main board and be done with it as it sometimes damages the processor some how and by the time you ship and bench fees it’s quicker and you pretty much get a new product with an updated main processor .
 
Gmoney

Gmoney

Audioholic Ninja
Does anyone know how I can flash the bios again on my receiver?
Can you post up a photo of your AVR showing "Error" on the front display? You have been told what needs to be done. Why would you ask on a forum if anyone on AH knows how to flash your AVR? When a Yamaha Tech has already had a phone call consultation with you for free.
 
Gmoney

Gmoney

Audioholic Ninja
Yes, I did that too. However after the factory reset the firmware version is still "error". I tried the online update, it didn't work either.
Than if you already done that than Why are you on a Forum asking how to flash your AVR? Try asking or guessing what to ask again when you don't get what your looking for on a Open Forum. You seem to know about your AVR, but yet you can't believe that it may have been something You did Wrong when You tried to do the update on Your AVR. I do believe it may be what you did wrong and Not Yamaha. I had a similar issue updating a Onkyo AVR years back, I got lucky cause it was what I did wrong when updating that unit. Got on the phone with Onkyo service tech and guess what? Tech walked me through it updating it to get my Onkyo back up and running right. Yes it was bricked Error code showed and nothing else on the front display panel.
 
Mark E. Long

Mark E. Long

Full Audioholic
Than if you already done that than Why are you on a Forum asking how to flash your AVR? Try asking or guessing what to ask again when you don't get what your looking for on a Open Forum. You seem to know about your AVR, but yet you can't believe that it may have been something You did Wrong when You tried to do the update on Your AVR. I do believe it may be what you did wrong and Not Yamaha. I had a similar issue updating a Onkyo AVR years back, I got lucky cause it was what I did wrong when updating that unit. Got on the phone with Onkyo service tech and guess what? Tech walked me through it updating it to get my Onkyo back up and running right. Yes it was bricked Error code showed and nothing else on the front display panel.
I’ve herd of guys haveing problems with downloading updates from Yamaha to usb drives myself I’d only use a hard wired connection to update . There’s just to much can go wrong on a WiFi connection and a usb download. One crupt part of the new file and poof your unit needs repaired .
 
D

darren.k

Audiophyte
How strange - my Aventage 1080 which has worked perfectly for 6 years has just today come up with this same error.. I don't think I've ever updated the firmware nor connected it to my router
 
D

darren.k

Audiophyte
Using the "pure direct" button I can get 2 channel audio out of it, I will post the solution as and when I deal with it (if nobody else gets there first)
 

newsletter
  • RBHsound.com
  • BlueJeansCable.com
  • SVS Sound Subwoofers
  • Experience the Martin Logan Montis
Top