Surround Speakers Not Engaging While Using Roku or TV Streaming.

S

SoundEro

Enthusiast
I finally upgraded my media room to 4K, installing these devices...

—Denon AVR-X4700H AV Receiver
—LG 4K OLED 77C1 77-inch Television (OLED77C1PUB)
—Panasonic DP-UB9000 Ultra HD 4K Blu-Ray Player
—Roku Ultra HDR 4K UHD Streaming Media Player (2020 Edition)

For now, I’m continuing to use the same DVR cable box (Arris 3600 Cable Box with Enhanced DVR (HD, 1080i box from Spectrum) and the same 5.1 Surround Sound speaker setup that had already been there.

All the devices are connected to my receiver.

I notice that, when I stream using the Roku device or via the apps that are built into the TV, my surround speakers are no longer engaged. They stay quiet, even for content that should have surround sound. For instance, I can watch a broadcast on my regular cable box that clearly uses my surround speakers. But that exact content, when streamed through the Roku or via the TV is in stereo only; no surround sound.

What is happening?

One thought: the TV is connected, using an HDMI cord, to the receiver’s HDMI Out HDCP 2.3 port. Is there also supposed to be a different connection to hear sound from the TV—or the Roku, for that matter—in surround? The Roku is connected to an HDMI In HDCP 2.3 port.
 
Last edited:
j_garcia

j_garcia

Audioholic Jedi
Since the Roku and TV both do it, it could just be a setting issue. TV apps usually suck, so that's not a surprise that the TV does that, but the box should have the capability. Check audio output settings on the Roku. It should be connected directly to the AVR, not the TV.

Then there are the services themselves. Just because they advertise certain features, does not mean all devices support those features. So you'll need to try to find out for the ones that aren't working, if those apps actually support surround on these devices.
 
T

Trebdp83

Audioholic Ninja
Hello and welcome! Make sure audio output on all devices as well as the TV are set to bitstream/best and not PCM. Some content will still come over in 2.0 sound so make sure you are using a surround mode such as Dolby Surround or DTS Neural/Virtual:X for each source input and not Direct or Stereo mode. Sound will only be produced from the FR and FL channels in Direct mode and the subwoofer will be added in Stereo mode when playing back 2.0 channel tracks.
 
S

SoundEro

Enthusiast
All my devices, including the Roku, are connected directly to my receiver. In the Roku, where, exactly, would I find Bitstream and the surround modes you listed? I see options for Auto, which supposedly chooses the best audio possible.

Just curious: can the receiver also control output settings on a port by port basis?
 
T

Trebdp83

Audioholic Ninja
Auto would be the right choice in the Roku. Turn OFF Volume Leveling in the Roku if it is on as it supposedly disables Atmos output if ON.

Sound/Surround modes will be selected using the Sound Mode buttons on the Denon remote control labeled MOVIE, MUSIC, GAME and PURE. For Auto processing of Dolby or DTS signals, press the PURE button until Auto mode displays.

Press the INFO button on the Denon remote control to see the input signal on the TV screen. If it is a two channel signal, you will want to select a surround mode if you are in Pure Direct, Direct or Stereo mode. Press the MOVIE button repeatedly until you reach the desired mode. The Quick Select buttons can save your settings.
 
Old Onkyo

Old Onkyo

Audioholic General
Why do I think the work around is to connect a digital optical cable?
 
T

Trebdp83

Audioholic Ninja
An optical connection wouldn’t fix a two channel PCM output issue from the TV. If the HDMI cable connecting the receiver and TV does not support ethernet, eARC will not work properly or at all. ARC will still work but only if HDMI-CEC is turned ON in the TV(Simplink) and the receiver.

Even with everything connected and set to output audio properly, the desired sound will not be achieved if the Denon is not set to a sound mode that makes use of all the speakers when a two channel signal is in play.

Since the speaker setup is 5.1, I would make sure the amp assignment is set for a basic(5.1) setup. The back surround and height speaker should be set to NONE. Make sure the surround speaker wires are connected to the Surround speaker terminals and no other Zones are ON.

With the speakers set to 5.1, you can turn on the Speaker Virtualizer for virtual height effects from the five speakers when playing Dolby Atmos tracks or non Atmos tracks in Dolby Surround mode. Playing DTS tracks in DTS Virtual:X will provide virtual effects as well.
 
S

SoundEro

Enthusiast
Auto would be the right choice in the Roku. Turn OFF Volume Leveling in the Roku if it is on as it supposedly disables Atmos output if ON.

Sound/Surround modes will be selected using the Sound Mode buttons on the Denon remote control labeled MOVIE, MUSIC, GAME and PURE. For Auto processing of Dolby or DTS signals, press the PURE button until Auto mode displays.

Press the INFO button on the Denon remote control to see the input signal on the TV screen. If it is a two channel signal, you will want to select a surround mode if you are in Pure Direct, Direct or Stereo mode. Press the MOVIE button repeatedly until you reach the desired mode. The Quick Select buttons can save your settings.
Thanks for your input, Trebdp.

Where would I find Volume Leveling on the Roku? I suspect it may be on, because when I pressed Movie on the remote for my receiver, Dolby Atmos was selected in the receiver but the surround speakers were still not engaged. Choosing Multi Channel Stereo engaged all the speakers again.

I also just realized that the HDMI cable that connects my receiver and TV supports ARC but apparently not eARC. I’m planning to replace the HDMI cables with ones that are eARC compatible. Will that resolve the audio issue?
 
lovinthehd

lovinthehd

Audioholic Jedi
While Multi-Channel Stereo uses more speakers, it's still only a 2.0 format, no indication you're getting multich audio....unless you deliberately override the actual multichannel signal.
 
Verdinut

Verdinut

Audioholic Ninja
Hello and welcome! Make sure audio output on all devices as well as the TV are set to bitstream/best and not PCM. Some content will still come over in 2.0 sound so make sure you are using a surround mode such as Dolby Surround or DTS Neural/Virtual:X for each source input and not Direct or Stereo mode. Sound will only be produced from the FR and FL channels in Direct mode and the subwoofer will be added in Stereo mode when playing back 2.0 channel tracks.
According to the Home Theater academy, both PCM and Bitstream can provide hi-res audio:
Bitstream and PCM are capable of producing the same audio quality, and the only difference is how your setup decodes the compressed file. Compatibility with devices and supported frequencies are bigger factors to consider than sound and transmission when choosing between PCM and bitstream.
 
T

Trebdp83

Audioholic Ninja
I’m familiar with multichhannel PCM. It’s a bandwidth issue. A TV that is outputting PCM over optical or ARC will down convert a multichannel Dolby or DTS signal. This results in a two channel PCM signal sent to the AVR. Things are different for eARC as it supports more bandwidth but that is not what is going on in this particular setup.
 
T

Trebdp83

Audioholic Ninja
Thanks for your input, Trebdp.

Where would I find Volume Leveling on the Roku? I suspect it may be on, because when I pressed Movie on the remote for my receiver, Dolby Atmos was selected in the receiver but the surround speakers were still not engaged. Choosing Multi Channel Stereo engaged all the speakers again.

I also just realized that the HDMI cable that connects my receiver and TV supports ARC but apparently not eARC. I’m planning to replace the HDMI cables with ones that are eARC compatible. Will that resolve the audio issue?
There is good information and instructions for volume mode in the link.
 
T

Trebdp83

Audioholic Ninja
It can be difficult to understand why surround channels aren’t working with some tracks. If a movie is labeled Dolby Vision and Dolby Atmos, one expects HDR and Atmos to work. But, settings in the streaming device, receiver and TV can prevent both from working at all.

Things can get more frustrating because multichannel tracks and two channel tracks can both be played in ALL CHANNEL STEREO MODE as well as regular two channel STEREO MODE. Pressing the info button will inform one of the incoming signal. If it is a two channel or multichannel signal and the surround speakers aren’t working in a Dolby/DTS mode, something is up. It may just be in STEREO MODE.
 
S

SoundEro

Enthusiast
It can be difficult to understand why surround channels aren’t working with some tracks. If a movie is labeled Dolby Vision and Dolby Atmos, one expects HDR and Atmos to work. But, settings in the streaming device, receiver and TV can prevent both from working at all.

Things can get more frustrating because multichannel tracks and two channel tracks can both be played in ALL CHANNEL STEREO MODE as well as regular two channel STEREO MODE. Pressing the info button will inform one of the incoming signal. If it is a two channel or multichannel signal and the surround speakers aren’t working in a Dolby/DTS mode, something is up. It may just be in STEREO MODE.
Yeah, I figured Multchannel Stereo Mode would be just that: multiple speakers engaged but still just stereo. And that’s exactly what it sounds like.

Thanks for the link. I did manage to turn off Volume Leveling on the Roku. But, when I select Dolby Atmos on the receiver, it is still not engaging all the speakers.

So, the use of eARC-compatible HDMI cables will not resolve these audio issues?
 
S

SoundEro

Enthusiast
So, I checked my receiver’s Info window while using the Roku and it showed that Dolby Atmos was set and that all the speakers were in use. But it didn’t sound like it. I then checked a couple other apps on the Roku. Now it appears Dolby Atmos is actually working in those apps (or maybe it was just certain shows/films). So, I suppose which apps are involved is a large part of the answer.
 
S

SoundEro

Enthusiast
With the speakers set to 5.1, you can turn on the Speaker Virtualizer for virtual height effects from the five speakers when playing Dolby Atmos tracks or non Atmos tracks in Dolby Surround mode. Playing DTS tracks in DTS Virtual:X will provide virtual effects as well.
Thanks for this tip. I finally found where the Speaker Virtualizer is in my receiver’s menus. It was already on.
 
T

Trebdp83

Audioholic Ninja
“But Beaver, they forgot to change the price and you’re basically getting the Stick+ for free!” “F#%kin’ Larry! There goes all my Christmas money!” But Beaver, now you will know the Roku inside and out and you can give me the Stick+ since you got it for free.” “F#%kin’ Larry!”
42AD74BF-DC08-4C56-9EC3-CEB990885311.jpeg
 
T

Trebdp83

Audioholic Ninja
Will have to start my own thread about the Roku Ultra. It’s as fun to use as it is frustrating for sure. I learned a few things tonight so let’s get started!

The Streaming audio format should be set to Auto BUT the Digital output format should be set to Passthrough and NOT Auto. When set to Auto, the signal is converted to Dolby Atmos and the Dolby light on the receiver comes on even if it is a two channel PCM signal from the main menus. BUT it does not change the channel output. So, a two channel audio track still only comes over the Front speakers in any mode except ALL CHANNEL STEREO. This was an unpleasant surprise and I’ve never seen this feature in any other device.o_O
 
T

Trebdp83

Audioholic Ninja
I played around with different apps on the Roku today. Like so many streamers, audio and video specs are all over the place for each app. With the Roku audio output settings recommended earlier, one can set it to Dolby Surround and kinda’ forget it.

Dolby Digital 5.1 and Dolby Digital Plus/Atmos tracks will play accordingly. Two channel PCM tracks will be processed by Dolby Surround mode properly and sound will be produced from all channels.

Dialogue bleed and other issues do plague Dolby Surround. DTS Neural:X/Virtual:X do a consistently better job with PCM 2.0 tracks. One
 
newsletter

  • RBHsound.com
  • BlueJeansCable.com
  • SVS Sound Subwoofers
  • Experience the Martin Logan Montis
Top