Optoma EH200ST lights glowing red and won't turn on

F

First

Audiophyte
I have an Optima EH200ST projector. I turned it on and used it briefly this morning, nothing was wrong with it, and then I turned it off. When I turned it back on a few hours later, it was making a loud humming sound. I turned it off, let it cool down, but when I turned it back on, the sound started up again. The screen would come on, though.

I turned it back off and kept it off for a few hours. When I tried to turn it back on, however, now the screen wouldn't come on and it wasn't even making the humming sound anymore. The only thing that happens is that two of the lights on the projector glow red. The one next to the power icon and the one next to the lamp icon. The other light doesn't glow, though.

I had a replacement lamp for the projector (and I've installed and uninstalled several projector lamps before and they all worked perfectly), but when I turned it on with the new lamp, it just did the same thing with the glowing red lights.

What could be wrong with it? Initially, I thought it was the fan, then I assumed it was the lamp, but after the replacement, I'm not sure what to think. I've only had it for a little over a year.

I'm willing to answer any other questions about the projector that may help in fixing it. Thank you very much in advance.
 
BMXTRIX

BMXTRIX

Audioholic Warlord
Sounds like the color wheel may have gone bad. If you are up for the challenge, and the projector is out of warranty, you will need to take it apart and check out the guts to see what is going on.

A BIG tool is FixItFrank on YouTube. He has a ton of projector teardown/rebuild videos and you can message him which can help you get some information and perhaps the right replacement parts.

This is not for the weak, but a buzzing DLP projector usually indicates a color wheel failure.
 

newsletter
  • RBHsound.com
  • BlueJeansCable.com
  • SVS Sound Subwoofers
  • Experience the Martin Logan Montis
Top