New Rotel RSP-1576 mkii / Apple TV Sound Delay

C

Chrispy1328

Audiophyte
Hi Everyone!

I recently upgraded my Marantz AVR/preamp to a Rotel RSP-1576mkii. The sound is phenomenal with my RMB 1555 and B&W 5.1 setup.

But there are a couple glitches/bugs/quirks, most noticeable with the Apple TV (which is what we use 90% of the time). Wondering if anyone else has these issues and if anyone has any suggestions?

1) When I start a program (regardless of which app or service I’m using), there’s a delay of several seconds before any sound comes on. Sometimes, after a commercial break too, the sound goes out for a couple seconds.
2) Sometimes, after I hit play on a program or when I finish one program a move to the next episode or a new show, the sound goes off entirely.
3) When I power on the system (regardless of whether I’m using Apple TV or another input), it takes upwards of a minute for the blue power light to stop blinking and the unit to complete its startup.

Very much appreciate any thoughts you might have!
 
lovinthehd

lovinthehd

Audioholic Jedi
Sounds like the Rotel is defective....do you still have the Marantz to see if its the ATV or not?

ps You might try a factory/microprocessor reset on the Rotel, too.
 
C

Chrispy1328

Audiophyte
Thanks — I’m afraid I don’t have the Marantz anymore, but I’ll try a factory reset.

Also good to know that I’m not crazy, and that’s not normal!
 
lovinthehd

lovinthehd

Audioholic Jedi
Is the one minute warmup time mentioned in the manual? Could be severe hdmi handshake issues I suppose, too....
 
C

Chrispy1328

Audiophyte
Is the one minute warmup time mentioned in the manual? Could be severe hdmi handshake issues I suppose, too....
Yeah, I thought maybe it could be the HDMI cables — replaced them with Audioquest Cinnamons, but alas no effect.

And no — I didn’t see anything in the manual about the startup time.
 
lovinthehd

lovinthehd

Audioholic Jedi
Yeah, I thought maybe it could be the HDMI cables — replaced them with Audioquest Cinnamons, but alas no effect.

And no — I didn’t see anything in the manual about the startup time.
Don't know what Fraudioquest would solve/prove :) Friends don't let friends buy Fraudioquest! HDMI handshake issues are generally not a cable thing, more the hardware involved.
 
C

Chrispy1328

Audiophyte
Don't know what Fraudioquest would solve/prove :) Friends don't let friends buy Fraudioquest! HDMI handshake issues are generally not a cable thing, more the hardware involved.
Thanks and thanks! That actually makes more sense than anything else I’ve come up with…

Are there interconnects or HDMI cables you suggest? I was afraid that may be the case — felt a little snake oil salesman, but I didn’t know better! ‍♂♂
 
lovinthehd

lovinthehd

Audioholic Jedi
I source cables from Monoprice generally, and have a Mediabridge one, too. Fraudioquest is dripping in snake oil.
 
P

PENG

Audioholic Slumlord
Thanks and thanks! That actually makes more sense than anything else I’ve come up with…

Are there interconnects or HDMI cables you suggest? I was afraid that may be the case — felt a little snake oil salesman, but I didn’t know better! ‍♂‍♂
Audioquest is very good at convincing people to spend more money than they need to!! I would never spend more than $20 for a 1 to 2 meter HDMI cable. As HD suggested, Monoprice's are fine.

Amazon.com : hdmi 2.1 cable
 
TLS Guy

TLS Guy

Audioholic Slumlord
Thanks — I’m afraid I don’t have the Marantz anymore, but I’ll try a factory reset.

Also good to know that I’m not crazy, and that’s not normal!
Yes, try up to three hard resets.

We get these sorts of posts pretty regularly that feature boutique brands with HDMI issues. This comes down to the fact that these brands do not have the resources to implement HDMI successfully. The problem is that HDMI and its associated HDCP codes are just ridiculously complicated, and totally defeat smaller outfits.

I had a Rotel pre/pro some years ago, but did not own it long. It has a list of issues.

I think basically your choice of reliable pre/pros comes down to Marantz or Yamaha. Even my latest Marantz 7705 was initially buggy, but quite a number of firmware updates over the first few months resolved the issues.

Let s know how you get on, but I'm fearful these issues will not resolve. If reset does not solve the issues, then if you are in the return window I would drop that Rotel like a hot potato.
 

newsletter
  • RBHsound.com
  • BlueJeansCable.com
  • SVS Sound Subwoofers
  • Experience the Martin Logan Montis
Top