ER15 Center Speaker Build Tweeter Rolloff

P

Pebble

Audiophyte
Ratings
4 1
#1
Hello,

I just finished building an ER15 Center channel per Meniscus' Audio's build (it wont let me put a link). I got the crossover and cabinet all setup, but I'm having issues where there is a significant rolloff on the tweeter from 4kHz to 20kHz. I ran a sweep from 3kHz to 20kHz both with and without the crossover and you can see the results below. I have double checked all the connections on the cross over and everything seems to be correct and connected (resistance check with DMM). I did some XSim simulations of the crossover and what appears to be happening is that 0.1mH inductor almost appears to have the frequency response as if it was a 1 mH inductor. If anyone has any ideas I would greatly appreciate them. I'm going to get an LCR meter from work and double check the 0.1 mH inductor tonight. Hopefully this isn't too many images, but I wanted to put as much info as I could.


Simulation_Of_CrossOver.png

Thanks

Raw_Driver_Response.png
CrossOver_Response.png
 
Last edited:
fuzz092888

fuzz092888

Audioholic Warlord
Ratings
4,833 42
#2
You are 100% not supposed to be posting the crossovers with values for a kit you bought from meniscus
 
fuzz092888

fuzz092888

Audioholic Warlord
Ratings
4,833 42
#4
I would still be hesitant about reposting that information before knowing exactly what agreement Meniscus has with Dennis. I believe Swerd posted that prior to Meniscus hosting the kit and I know Dennis is almost always happy to share information on his projects that he isn't selling or that he wasn't contracted for, but all of the kits I've bought from Meniscus included a disclaimer that you were not supposed to post or share cabinet dimensions/drawings and crossover details. Perhaps they have a different agreement with Dennis.
 
P

Pebble

Audiophyte
Ratings
4 1
#5
On the original thread, ARES24 mentioned that Meniscus was offering a kit before this image was posted by Swerd. I saw no such disclaimer within my paperwork for the kit.

Edit: I also noticed that you even posted on that particular thread.
 
Last edited:
P

Pebble

Audiophyte
Ratings
4 1
#6
I would still be hesitant about reposting that information before knowing exactly what agreement Meniscus has with Dennis. I believe Swerd posted that prior to Meniscus hosting the kit and I know Dennis is almost always happy to share information on his projects that he isn't selling or that he wasn't contracted for, but all of the kits I've bought from Meniscus included a disclaimer that you were not supposed to post or share cabinet dimensions/drawings and crossover details. Perhaps they have a different agreement with Dennis.
I ended up calling up Meniscus. They said to check with Dennis on the crossover, so I ended up just removing the drawing from the OP. After speaking with them, it sounds like the batch of the 0.1mH inductors they got actually read 0.5mH so it's very likely that is my issue. I will check the inductor with my LCR when I get home tonight to confirm.
 
jinjuku

jinjuku

Moderator
Ratings
1,968 3
#7
Hey guys, if a member gets a kit and is having a problem, I don't see a problem discussing it and trouble shooting it here.

If there is any 'agreement' with Meniscus, AH isn't the thought police on quashing the information needed to successfully troubleshoot.

Those issues are between the purchaser and Meniscus.
 
P

Pebble

Audiophyte
Ratings
4 1
#8
Issue solved. I had a 0.5mH inductor instead of the 0.1mH. I ended up unwinding it to 0.1mH and took some more measurements once it was back together and everything is working correctly now.
 

newsletter
  • RBHsound.com
  • BlueJeansCable.com
  • SVS Sound Subwoofers
  • Experience the Martin Logan Montis
  • CEDIA