Roku Not Displaying 4K Consistently.

S

SoundEro

Enthusiast
My setup is as follows:

—Denon AVR-X4700H AV Receiver
—LG 4K OLED 77C1 77-inch Television (OLED77C1PUB)
—Panasonic DP-UB9000 Ultra HD 4K Blu-Ray Player
—Roku Ultra HDR 4K UHD Streaming Media Player (2020 Edition)
—5.1 Surround speaker system

Right out of the box, I noticed that my Roku Ultra does not consistently recognize that I have a 4K television and setup. In fact, more often than not, it’s convinced my system is no better than 1080p. As a result, it streams content in 1080p.

The Roku is erratic when it checks to verify my connected TV is a 4K device. Sometimes it guesses correctly; other times, it guesses wrong. On the occasions that it does recognize my 4K system, the stream, especially while running Netflix, becomes spotty, blacking-out, flashing white or displaying an error message that states 4K is not available. I’m planning to replace the HDMI cables that connect the Roku to my receiver. Don’t know if that will solve the issue.

What else could be causing this problem?
 
T

Trebdp83

Audioholic Ninja
You need at least 18gbps premium certified HDMI cables that support ethernet in your particular case. Get cables for every connected device, receiver and TV. You will have blackouts and other issues with lesser cables.
 
T

Trebdp83

Audioholic Ninja
Once new cables are connected, make sure UHD Color setting is On in the TV and the HDMI mode in the Denon is set to 4K Enhanced and not Standard so full HDR makes its way from your devices to the TV.
 
S

SoundEro

Enthusiast
Okay. Thanks, Trepdp. My new HDMI cables are due to arrive on Friday (I hope).
 
S

SoundEro

Enthusiast
Well, I received my new set of HDMI cables and used them to connect both the Roku Ultra to the receiver and the TV to the receiver. Then, in the Roku, I tried Settings > Display type > Auto detect...and I still received the same message that the HDMI connection can only accommodate up to 1080p video because HDCP 2.2 isn’t supported.

I had also explored the settings on my receiver and TV and thought I made the right changes there, too. Maybe not? What am I doing wrong (if anything)?

Should I try sending the Roku back to the retailer for a replacement?
 
T

Trebdp83

Audioholic Ninja
Try connecting the Roku directly to the TV. What does it do there?
 
panteragstk

panteragstk

Audioholic Warlord
Well, I received my new set of HDMI cables and used them to connect both the Roku Ultra to the receiver and the TV to the receiver. Then, in the Roku, I tried Settings > Display type > Auto detect...and I still received the same message that the HDMI connection can only accommodate up to 1080p video because HDCP 2.2 isn’t supported.

I had also explored the settings on my receiver and TV and thought I made the right changes there, too. Maybe not? What am I doing wrong (if anything)?

Should I try sending the Roku back to the retailer for a replacement?
Don't send it back yet, this is just another HDMI handshake issue.

Make sure you don't have any scaling settings on your AVR, those can do strange things with the signal, but usually not this.

Is there a way to force the resolution on the roku?
 
T

Trebdp83

Audioholic Ninja
The Roku is a stubborn thing. Even if one forces a 4K HDR setting for the display, it will auto detect on the next power up anyway. Go into the Advanced system settings and then into the Advanced display settings. Turn "Auto-adjust display refresh rate" to ON. Set "HDR subsampling" to 4:2:0. Turn "HDR always on" to OFF.

I still recommend a direct connection to the TV just to rule out AVR settings. If the problem persists, check everything. Hopefully, those are Premium Certified(18gbps with ethernet support) or Ultra Premium certified cables(48gbps). If the cables are the 18gbps variety, they need to support ethernet for eARC to work properly.

Check the Denon settings to see if the HDCP spec for each HDMI port is set to Auto or 2.3 and NOT 1.4. The Denon should also be set to 4K Enhanced for HDR passthrough if using 18gbps cables. You can set it to 8K Enhanced if using 48gbps cables and the TV should have its UHD Deep color set to ON.
 
H

Hobbit

Senior Audioholic
Right out of the box, I noticed that my Roku Ultra does not consistently recognize that I have a 4K television and setup. In fact, more often than not, it’s convinced my system is no better than 1080p. As a result, it streams content in 1080p.
I've had no issues with my ROKU. First, are you sure you're streaming at 4k? Not all content is 4K and it will revert to 1080p when the streaming content is not 4k. It does not detect your tv and then transmit in 4k. It does auto detect, but then transmits based on content. Second, as a whole, the biggest difference I can see with 4k is the HDR and color palet. For example, the shadows aren't as pixelated. It's not like going from 480 to 1080.
 
panteragstk

panteragstk

Audioholic Warlord
The OP has an LG TV and a Roku Ultra. How do the Roku TVs relate to this? (my knowledge of Roku TVs is absolute zero, so it's entirely possible I'm missing something).
TVs with the Roku OS, or whatever they call it, as the main way to do anything with that TV. Amazon has FireOS in TVs and Android TV is on anything from low end to high end TVs. LG and Samsung have their own OS, and I'm sure others do as well.

Super fun to navigate when it comes to app compatibility.
 
T

Trebdp83

Audioholic Ninja
I've had no issues with my ROKU. First, are you sure you're streaming at 4k? Not all content is 4K and it will revert to 1080p when the streaming content is not 4k. It does not detect your tv and then transmit in 4k. It does auto detect, but then transmits based on content. Second, as a whole, the biggest difference I can see with 4k is the HDR and color palet. For example, the shadows aren't as pixelated. It's not like going from 480 to 1080.
That isn't the case with the Roku Ultra or many streamers. It can be set to output native HDR and 24Hz material but the resolution output will be set to that of the connected TV. Any content resolution below 4K will be upscaled. There are many settings involving the Roku Ultra, AVR and TV that need to be set correctly for all to work as they should. In the @SoundEro case, there is something going on that nobody can know for sure as none of us are in front of the system to check the settings.
Fascinated and frustrated with the Roku Ultra
 
H

Hobbit

Senior Audioholic
That isn't the case with the Roku Ultra or many streamers. It can be set to output native HDR and 24Hz material but the resolution output will be set to that of the connected TV. Any content resolution below 4K will be upscaled. There are many settings involving the Roku Ultra, AVR and TV that need to be set correctly for all to work as they should. In the @SoundEro case, there is something going on that nobody can know for sure as none of us are in front of the system to check the settings.
Fascinated and frustrated with the Roku Ultra
Hmmm you're right, I checked earlier, my ultra is always up-sampling to 2160p. I'm using the simple auto-detect setting on the Roku.

Now that you jolted my memory, I do recall a setting in my Denon AVR that I needed to go in and set to get this working correctly. I remember it annoyed the heck out of me that in many ways all our fancy equipment is like back in the old USB days: plug and pray. At one point I was going to/did bypass the AVR with the ROKU, but that caused other user issues.

Then I used Google and found a way. I just did a search and came up with this. It looks familiar to what I had to do to get it to work properly.

How to setup 4k hdr on Denon AVR.......

 
Last edited:
Teetertotter?

Teetertotter?

Full Audioholic
Ya, when I received my Denon S 960H this past summer, and like other Denon AVR's, I go through all the menu's and adjust accordingly. I set my 4K to "Enhanced." Also, check that your HDMI Upscaling is turned on too.
 
T

Trebdp83

Audioholic Ninja
There are simply too many settings these days and too many streamers that do not have simple passthrough features for audio and video. AVR upscaling can just as well be left off. Remember that, when using a 4K TV, it will upscale everything thrown at it that is not 4K. You'd think those folks that advocated for "Film Maker" mode in TVs would also have screamed at the streaming services and device makers. You can really butcher up some content from device, to AVR and then in the TV itself and have an extremely compromised presentation.

While new TVs and AVRs can handle any audio/video stream devices can throw at them, many are using systems with a mix of older and newer devices. Streamers, disc players and game consoles deal with these systems with varying degrees of success. Throw in soundbars and things get even messier. It is ridiculous that somebody using a new streamer, AVR and TV cannot simply set everything to bitstream and/or passthrough and let the AVR and TV do what they do best.

Different manufacturers use different designations for features. Anytime anybody has an issue with their system and looks for help online, they simply must include the make and model of every piece of the system as well as every cable used for connection and every setting in each device. It all matters as these new systems get more and more complex. It's not nearly as simple as connecting yellow, white and red analog cables from a device to a system. HDCP ruined everything. But, that is for another thread.
 
S

SoundEro

Enthusiast
Thanks for all the responses, everyone.

I finally had some time to troubleshoot, following some of your suggestions and looking at the manuals and onscreen help for the various devices involved. I’m pleased to report that my Roku is finally acknowledging and using my 4K setup.

—I upgraded all the HDMI cables for my entire setup to ones that accommodate eARC.
—I made sure the video setting on my AV receiver was set to 4K Enhanced.
—Then, I found one more setting on the TV itself. It was buried in a somewhat obscure, nonintuitive location. But I found it. Essentially, this setting enabled connected devices to display in 4K. And, by default, it was turned off. I turned it on for the first time...
—then tried the video settings in the Roku again...
—and, just like that, the Roku started to display in 4K with no more errors.

The other thing is that the 4K toggle on the TV is applied on a port by port basis. So, the particular feature can be turned on for one device, but left off for others.

So, the resolution is, at last, resolved. Now I just need to calibrate the set and fine tune the color...
Then, I’ll try to avoid touching the settings again, lol.

So many variables.
 

Latest posts

newsletter

  • RBHsound.com
  • BlueJeansCable.com
  • SVS Sound Subwoofers
  • Experience the Martin Logan Montis
Top