Onkyo TX696 and Fios new 4k cable box Issues

Epsonfan

Epsonfan

Enthusiast
Having issues with Onkyo Tx696 and Fios 4k cable box. The receiver hooked up to the LG OLED TV via HDMI ARC and Fios box hooked up to the receiver in the Cable/Sat HDMI slot I don't see any pic but a blue screen. What am I doing wrong here ?...
 
lovinthehd

lovinthehd

Seriously, I have no life.
You have another source (like a bluray player) that will work? Does the tv have apps that work? You get audio okay? You have an appropriate high speed hdmi cable? Try turning tv on first then avr then cable box, too. Just in case, what make/model of tv?
 
Epsonfan

Epsonfan

Enthusiast
I am streaming Apple TV and Blue Ray player they all working fine except the Fios ST box connected that's via HDMI. The Apps on TV are working no problem, my tv is LG OLED 55 inch.
I did switch to a different HDMI cable to no avail
 
Epsonfan

Epsonfan

Enthusiast
I finally figured out I had to change the EDID settings in the Onkyo which has three settings 1,2 and 3 so I picked no2 and now it's all good.
 
lovinthehd

lovinthehd

Seriously, I have no life.
I finally figured out I had to change the EDID settings in the Onkyo which has three settings 1,2 and 3 so I picked no2 and now it's all good.
Was just looking at Denon's page on hdmi diagnostics including edid (new to me, my older gear does not have)...does the Onkyo have diagnostics you can run similarly?
 
Epsonfan

Epsonfan

Enthusiast
Not that I noticed it I was just going through the menu and I happen to come across the EDID thingy and I tried it and it worked for me. Now I have another issue where the Fios remote is not responding when I press the volume and other buttons work fine. Thanks for help tho
 
lovinthehd

lovinthehd

Seriously, I have no life.
I took a look in your manual, no indication at least on a user level...maybe something a service menu might address. Glad you got it sorted. What is the Fios remote controlling volume for, your avr?
 
TLS Guy

TLS Guy

Audioholic Slumlord
Was just looking at Denon's page on hdmi diagnostics including edid (new to me, my older gear does not have)...does the Onkyo have diagnostics you can run similarly?
EDID conflicts are just another to add to the long list of HDMI hassles. Glad the OP figured it out.
 
Epsonfan

Epsonfan

Enthusiast
Speaking of the Denon. I had the X6500 and I moved it from HT to the bedroom for a while but boy the Amp section on X6500 gets pretty warm tho I had it in economy mode. As far as the bass Denon X6500 is out of this world. I am settling down with Onkyo because I really like the interface, the pic through HDMI ARC looks much better to my eyes & plus offers lots of other goodies for less money.
 
Epsonfan

Epsonfan

Enthusiast
I took a look in your manual, no indication at least on a user-level...maybe something a service menu might address. Glad you got it sorted. What is the Fios remote controlling volume for, your avr?
That's true but my wife uses the Fios remote and complains about the volume
 
lovinthehd

lovinthehd

Seriously, I have no life.
That's true but my wife uses the Fios remote and complains about the volume
Well if your volume is controlled by the avr, as it should, then you should leave the volume on the fios out of it, get her a universal remote that does it automatically perhaps.
 

Latest posts


newsletter
  • RBHsound.com
  • BlueJeansCable.com
  • SVS Sound Subwoofers
  • Experience the Martin Logan Montis
Top