No voice sound thru receiver while on premium channels

D

DanT

Audiophyte
I just stumbled across this site and it looks great. Piece by piece I’m putting together a sound system which is made up on Onkyo tx-sr373 and two Klipsch tower speakers and a sub-woofer.

I have my Samsung Q90 TV connected to the receiver using a HDMI cable from ARC to ARC. A problem I’m having is when I’m watching HBO I’m hearing sound and it sounds good but when people talk I’m not hearing conversations but the background sound still comes thru.

What am I doing wrong?
 
T

Trebdp83

Audioholic Samurai
Hello and welcome. Go into your speaker assignment settings and make sure you have it setup for a 2.1 system and not a 5.1 system or it will send dialogue information to a center channel speaker that does not exist in your setup.
 
D

DanT

Audiophyte
Thanks Trebdp83. Your comment about the center speaker got me thinking again and after more reading and research I realized I didn't have the Roku connected right. So now, the Roku goes into the receiver and out to the TV. And, I added a center speaker. The system sounds great, thanks.
 
T

Trebdp83

Audioholic Samurai
Joy! Make sure you are getting all of the video goodness as well. Make sure UHD color is ON for the TV's HDMI ARC port. Check the External device settings in the TV to make any needed changes. Make sure the Onkyo is in Enhanced mode for full HDR passthrough. You can turn it on by pressing and holding down the BD/DVD button on the front panel and then using another finger to press the ON/STANDBY button. After pressing the ON/STANDBY button, Standard may appear on the front display. Keep holding the BD/DVD button and give the power button another press. It should display Enhanced on the display and you can let go of the BD/DVD button. Make any adjustments needed to the Roku to pass HDR as well. You should see HDR10 appear for a moment onscreen when starting HDR content. Happy watching!
 

Latest posts


newsletter
  • RBHsound.com
  • BlueJeansCable.com
  • SVS Sound Subwoofers
  • Experience the Martin Logan Montis
Top