Marantz SR 8012 No Sound & distorted sound after 70 volume Level

K

kaptan

Enthusiast
Ratings
1
#1
One of my firend recently bought Marantz SR8012. Once he connected the speakers He did not get any sound but when raising the volume after level of 70 the audio is distorted.
let us know your thoughts on it to help him.

thanks
 
P

PENG

Audioholic Overlord
Ratings
3,979 6 1
#2
One of my firend recently bought Marantz SR8012. Once he connected the speakers He did not get any sound but when raising the volume after level of 70 the audio is distorted.
let us know your thoughts on it to help him.

thanks
That is not enough information to troubleshoot. I suggest he remove all speaker connections, do a factory reset and then start again by connecting one speaker to one channel at a time, each time making very sure there is not "short circuit" between the red and black terminals, preferably use a pair of "purchased" speaker wires already terminated in banana plugs and proven in working order. The safest way is to return the unit to the dealer and let them sort it out.
 
K

kaptan

Enthusiast
Ratings
1
#3
have done the below,

Reset the avr
Used banana plugs
Used a different speaker.

But still its the same. There are not even test tones coming out from the speakers in the setup menu.
 
P

PENG

Audioholic Overlord
Ratings
3,979 6 1
#4
have done the below,

Reset the avr
Used banana plugs
Used a different speaker.

But still its the same. There are not even test tones coming out from the speakers in the setup menu.
If the unit appeared to be powering on and off normally, then I still think it could be something simple that he/you missed. The 8012 is an expensive AVR so I think he should send it back for a replacement asap, unless the dealer can solve the problem. It is hard to troubleshoot something like this online.
 
DigitalDawn

DigitalDawn

Audioholic
Ratings
57 2
#5
Are his speakers 4 or 6 ohms? If yes, you need to set the AVR to the appropriate Ohm load.
 
AcuDefTechGuy

AcuDefTechGuy

Seriously, I have no life.
Ratings
5,855 14 6
#7
Most obvious reason would be a defective unit. I hope not, but sadly possible.

Able to return?

@PENG, sadly every time I see this, it makes me want to just get a X3000 for cheap and throw away in a few years if it breaks. :(

I mean after my 10-year-old Denon’s die first. :D
 
P

PENG

Audioholic Overlord
Ratings
3,979 6 1
#9
Most obvious reason would be a defective unit. I hope not, but sadly possible.

Able to return?

@PENG, sadly every time I see this, it makes me want to just get a X3000 for cheap and throw away in a few years if it breaks. :(

I mean after my 10-year-old Denon’s die first. :D
Did you know BB Canada has the X3400H brand new for C$799, that's better than Amazon.com's and bestbuy.com's, factoring in the exchange rate of 0.77 Very unusual deal in terms of US vs CA
 
AcuDefTechGuy

AcuDefTechGuy

Seriously, I have no life.
Ratings
5,855 14 6
#10
Did you know BB Canada has the X3400H brand new for C$799, that's better than Amazon.com's and bestbuy.com's, factoring in the exchange rate of 0.77 Very unusual deal in terms of US vs CA
The X3500 must be coming out soon. Even dealers are getting discounts on the x3400. Amazon US had the x3400on sale brand new for $599 a few days ago, but went up to $799 now. Up all these movements could mean the X3500 is imminent.
 

newsletter
  • RBHsound.com
  • BlueJeansCable.com
  • SVS Sound Subwoofers
  • Experience the Martin Logan Montis
  • CEDIA