Apple TV sound delayed?

T

T.Anders

Enthusiast
I don't have many ATV movies, but I do have a few older ones. Mainly, ones that are in 24fps and you can't find the Blu Ray/DVD for. For some reason, the new Gen 2 Apple TV 4K seems to delay sound on 24fps movies. This didn't happen on the old one. I made sure my Denon was set to pass through. Also made sure the ATV was set to match frame rates. I've tried combination of a few different settings with DD and Atmos as well.

I bought Fury because it was $9, and it doesn't have the same issue. I also bought Inception to try and see another movie, and it too had no issue.

Anyone else had this issue and solved it?

Apple simply keeps telling me to factory reset the device, and I've done that twice. No go.
 
Mark E. Long

Mark E. Long

Senior Audioholic
I’ve noticed that on the Apple TV streaming app on some movies had to set the lip sync in my Yamaha back to zero and turned processor For video to direct. I let the tv do the upscale to 4 K I noticed it on regular tv channels as well but that fixed it on my setup I’ve got a Yamaha avr tho .
 
highfigh

highfigh

Audioholic Slumlord
I don't have many ATV movies, but I do have a few older ones. Mainly, ones that are in 24fps and you can't find the Blu Ray/DVD for. For some reason, the new Gen 2 Apple TV 4K seems to delay sound on 24fps movies. This didn't happen on the old one. I made sure my Denon was set to pass through. Also made sure the ATV was set to match frame rates. I've tried combination of a few different settings with DD and Atmos as well.

I bought Fury because it was $9, and it doesn't have the same issue. I also bought Inception to try and see another movie, and it too had no issue.

Anyone else had this issue and solved it?

Apple simply keeps telling me to factory reset the device, and I've done that twice. No go.
Did you check the TV's menu, to see if that's where the delay is happening?

Also, 'pass-through' is usually used for the cable box, because that was the source used by most people when they didn't need the rest of the system to be operating- that way, they could use the TV's speakers and not be too loud for the rest of the house.
 
K

KurantAK

Enthusiast
I don't have many ATV movies, but I do have a few older ones. Mainly, ones that are in 24fps and you can't find the Blu Ray/DVD for. For some reason, the new Gen 2 Apple TV 4K seems to delay sound on 24fps movies. This didn't happen on the old one. I made sure my Denon was set to pass through. Also made sure the ATV was set to match frame rates. I've tried combination of a few different settings with DD and Atmos as well.

I bought Fury because it was $9, and it doesn't have the same issue. I also bought Inception to try and see another movie, and it too had no issue.

Anyone else had this issue and solved it?

Apple simply keeps telling me to factory reset the device, and I've done that twice. No go.
So sounds like you and I are in the same boat. You might have convoluted your testing a bit, I only say that because I’ve done a ton of of it.

The problem seems to be with update 14.5. Bottom line is this, anything the ATV is encoding in Atmos or content you do not force into DD 5.1 has the delay. I have a Denon X6700H and even when not passing through the delay exists. I have like you forced my receiver into other formats but the delay is still there for every movie as long as Atmos is enabled, whether using the format or not. Forcing into DD by allowing it to change formats fixes the delay. The inherent problems for me however is Atmos content no longer works.

The issue is definitely Apple’s problem. It’s a common complaint in their tech support forums. The problem is Apple is only recommending a factory reset.Mine was 14.5 out of the box. My older 4K is still 14.4 and the problem doesn’t exist.

So for now, until Apple recognizes the issue, it’s the waiting game. Huge disappointment.
 
S

snakeeyes

Audioholic Ninja
I run ATV 4K gen1 for Apple Music but I may at some point promote it to Video duty. I use the 2019 FireCube 4K for now.
 
T

Trebdp83

Audioholic Samurai
Apple needs to bitstream all audio signals at this point. The decoding and output of PCM is not a big deal until one tries to play an atmos track. For a moment, a receiver may display DTHD before recognizing the atmos/PCM signal. Different receivers will sort it out in different times. My Onkyo took about a second or two while the Yamaha took about five seconds. Now on the latest firmware, the Yamaha does it in about the same time as the Onkyo. This is the result while using an Apple TV 4K Gen 1 running 14.6.
 
S

snakeeyes

Audioholic Ninja
I watched a few movies on Saturday on my gen1 ATV 4K but all were 5.1 and I upmixed them with DSU to 5.1.4. The new gen2 remote works good by the way. :)
 

newsletter
  • RBHsound.com
  • BlueJeansCable.com
  • SVS Sound Subwoofers
  • Experience the Martin Logan Montis
Top