Surge protection/power conditioner recommended?

S

ssmokeyy

Audioholic Intern
mtrycrafts This guy is amazing at his craft. He used to work for phoenix gold. He had made me 3 amps based on the ti line. He has done so much work for me its not funny. He has more money spent in his shop than most people spend on there homes buying them. He also tests everything in his shop for 7 days and if it passes he sends it out if it fails he lets u know and goes back in and finds out why and fixes it.
 
TLS Guy

TLS Guy

Seriously, I have no life.
brand new.
Did you just plug in the h15, or was any gear plugged into it.

If there was nothing connected to your h15, then I'm suspicious of your house electrical system, like a live neutral swap for instance. This is just NOT typical for APC gear, and I suspect you have a problem somewhere.
 
mtrycrafts

mtrycrafts

Seriously, I have no life.
Did you just plug in the h15, or was any gear plugged into it.

If there was nothing connected to your h15, then I'm suspicious of your house electrical system, like a live neutral swap for instance. This is just NOT typical for APC gear, and I suspect you have a problem somewhere.
He did state this above:
Wa state usa. I have the apc 15h and panamax m5300 pm all ready. I have rewired my whole house. I do have whole house surge. When I built the theater room I used 10 ga 5 runs to the front and 12 ga for the lights. Ps audio outlets. I had two brand new apc h15 power conditioner but like I said one blew on plug in. Tested the outlet and plugged another box in and it was fine. I also have upgraded brakers in the new box. All.copper build box.

If that was the same outlet that other component was plugged into it too would have smoke, no? He rewired the whole house though, who knows.
 
Last edited:
TLS Guy

TLS Guy

Seriously, I have no life.
He did state this above:
Wa state usa. I have the apc 15h and panamax m5300 pm all ready. I have rewired my whole house. I do have whole house surge. When I built the theater room I used 10 ga 5 runs to the front and 12 ga for the lights. Ps audio outlets. I had two brand new apc h15 power conditioner but like I said one blew on plug in. Tested the outlet and plugged another box in and it was fine. I also have upgraded brakers in the new box. All.copper build box.

If that was the same outlet that other component was plugged into it too would have smoke, no? He rewired the whole house though, who knows.
That is a definite not necessarily.
 
S

ssmokeyy

Audioholic Intern
It was the apc box. I hooked up the second h15 and no problems. I have tested it with other gear no problem. Also i know how to wire a house. I'm the guy that all my friends come to and my customers of my business. That doesn't matter here. my luck is just bad these days. ge came out to fix there stove and broke it more than it was before they got here.
 
mtrycrafts

mtrycrafts

Seriously, I have no life.
It was the apc box. I hooked up the second h15 and no problems. I have tested it with other gear no problem. Also i know how to wire a house. I'm the guy that all my friends come to and my customers of my business. That doesn't matter here. my luck is just bad these days. ge came out to fix there stove and broke it more than it was before they got here.
Pop the cover if you still have it. They miss wired something in it.
 
newsletter

  • RBHsound.com
  • BlueJeansCable.com
  • SVS Sound Subwoofers
  • Experience the Martin Logan Montis
Top