Onkyo TX-SR605 Receiver: Center speaker not working

Discussion in 'Amps, Pre-Pros & Receivers' started by allen642, Jan 1, 2010.

  1. allen642 Audiophyte

    allen642
    Joined:
    Jan 1, 2010
    Messages:
    3
    Likes Received:
    0
    Location:
    Goodyear, AZ
    I ordered the Onkyo HT-SP908 7.1-channel home theater system from Amazon.com. The receiver that came with it is the TX-SR605. I am having a problem with the center speaker not working. I have hooked everything up correctly but the center speaker will not put out any sound. I know the speaker is good because I hooked it up to one of the other speaker wires and it works fine; also tried different speaker wires but nothing. I hooked one of the other working speakers up to the center connection on the back of the receiver and I get nothing. I think there might be a problem with the center connection on the receiver. Also when I put it through the Automatic Speaker Setup (Audyssey 2EQ) function it did not even recognize the center speaker. Everything else seems to be working fine. What do you suggest? Any help would be greatly appreciated. Please advise.
  2. Adam Audioholic Jedi

    Adam
    Joined:
    Jul 5, 2006
    Messages:
    32,017
    Likes Received:
    11,847
    Location:
    Tucson, Arizona
    Welcome to the forum!

    The fact that the auto setup isn't detecting the center channel is concerning, but let's try something. Did your new system come with the TX-SR605 owner's manual (it seems like it would based on Onkyo's support page)? If so, check out page 70 and 71 for the "Advanced Setup - Speaker Configuration" section and look at step 6. Make sure that the center channel is not set to "None."

    If you would, let us know if that helps out. If not, we'll keep trying.
    Adam,
  3. allen642 Audiophyte

    allen642
    Joined:
    Jan 1, 2010
    Messages:
    3
    Likes Received:
    0
    Location:
    Goodyear, AZ
    Checked it out. It was set to 'none'. I set it to 100 hz like the L & R, but still get nothing from it.
  4. Adam Audioholic Jedi

    Adam
    Joined:
    Jul 5, 2006
    Messages:
    32,017
    Likes Received:
    11,847
    Location:
    Tucson, Arizona
    It sounds like you've done all the right things: swapping speakers and speaker wires to try to diagnose the problem. The only other thing that I can think of is to inspect the center channel speaker terminals on the 605 and see if anything stands out to you.

    Given what you've said, I suspect that you got a defective unit. That's always the last thing that I want to say, but I think it's the case. If you swapped speakers and wires (that you know work), and the auto setup still won't detect a center channel, I don't know what else would cause that.

    If I'm missing something, I sure hope that others here will chime in. Otherwise, my advice is to contact Amazon for a replacement. I don't believe that you'll be charged anything at all if the unit is defective.
    Adam,
  5. allen642 Audiophyte

    allen642
    Joined:
    Jan 1, 2010
    Messages:
    3
    Likes Received:
    0
    Location:
    Goodyear, AZ
    Thank you. I think the center channel is defective also. I have contacted Onkyo but haven't gotten an answer back as of yet. Have a great day...
  6. Adam Audioholic Jedi

    Adam
    Joined:
    Jul 5, 2006
    Messages:
    32,017
    Likes Received:
    11,847
    Location:
    Tucson, Arizona
    No problem. You might be thinking this already, but I highly recommend exchanging it through Amazon before sending it in for service. You should get a working unit for your money, and Amazon shouldn't give you any problems at all if you're within their 30-day (I think) exchange window.

    Have a great day, yourself!
    Adam,
  7. pzaur Audioholic Samurai

    pzaur
    Joined:
    Feb 19, 2006
    Messages:
    2,218
    Likes Received:
    664
    Location:
    Phoenix
    That sounds like a crossover setting...

    -pat
  8. sholling Audioholic Ninja

    sholling
    Joined:
    Jun 7, 2006
    Messages:
    3,581
    Likes Received:
    1,009
    Location:
    Hemet California
    Amazon is great about returns within their 30 day window. With a defective item they will probably even pay for the shipping.

Share This Page

  • rbhsound.com
  • BlueJeansCable.com
  • Emotiva.com
  • SVS Sound Subwoofers
  • Experience the Martin Logan Montis
  • CEDIA