no picture or sound after using my Blu-ray

Discussion in 'CD/DVD/Blu-ray & Misc Hardware' started by berserkley, Nov 20, 2012.

  1. berserkley Audiophyte

    berserkley
    Joined:
    Nov 20, 2012
    Messages:
    3
    Likes Received:
    0
    I have a Panasonic Blu-ray, model DMP-BD65, and a Toshiba flat screen. My problem is that after everytime I use the Blu-ray, the monitor stays blank for up to 5 minutes (no sound, black screen), it then comes back on, no problem. Can anyone help me on this. (You know I'm going to kick myself if the answer is blatantly obvious!)
  2. Adam Audioholic Jedi

    Adam
    Joined:
    Jul 5, 2006
    Messages:
    32,076
    Likes Received:
    11,908
    Location:
    Tucson, Arizona
    Welcome to the forum!

    What equipment are you using besides the blu-ray player and the screen? Do you have the player connected through a receiver?

    Also, after you watch a blu-ray, what do you do? Do you switch to another source, like a cable box?

    If you are using an HDMI connection, then it sounds like a handshake issue - but I've never heard about it taking that long to reconnect. My system takes maybe five seconds to switch between HDMI sources using my receiver (it's faster when switching between HDMI sources on my TV).
    Adam,
  3. berserkley Audiophyte

    berserkley
    Joined:
    Nov 20, 2012
    Messages:
    3
    Likes Received:
    0
    Oops! Forgot to mention, it's also connected to a Comcast HD cable box.
  4. jdsimons2 Enthusiast

    jdsimons2
    Joined:
    Nov 27, 2012
    Messages:
    10
    Likes Received:
    0
    It sounds like something is up with a device that's connected between the Blu-Ray and TV!

Share This Page

  • EMPTek.com
  • BlueJeansCable.com
  • SVS Sound Subwoofers
  • Experience the Martin Logan Montis
  • CEDIA